INTER-AS INTERNET ACCESS
Bonjour,
Dans le cadre de la préparation de mon CCIE de l'optimisation de mon réseau et de ma disponibilité je ferai toujours de plus en plus de post sur les protocoles BGP et MPLS qui en mon sens sont des protocoles indispensables chez les service provider ( SP)
Aujourd'hui nous allons voir comment il est possible à un très petit ISP présent dans un ville
de pouvoir utiliser le réseau d'un grand ISP pour pouvoir fournir la connectivité INTERNET dans tout un PAYS
Nous allons prendre pour les besoins du LAB MTNC qui est le plus gros operateur au Cameroun et INFOGENIE qui lui est plus petit et présent pour l'instant que dans la ville de Yaoundé
La problématique est comment INFOGENIE peut utiliser le réseau de MTNC pour connecter un client à Maroua en faisant trafiquer son trafic vers son propre BRAS ( ce qui permet à INFOGENIE de fabriquer lui même ses plans de services )
Nous allons fortement nous inspirer du VPN/MPLS interAs de type A encore appelé Back to Back VRF
Quelques remarques
- Nous aurions également pu simplement utiliser du L2VPN mais nous aurions eu un soucis de "scalability"
- La connectivité vpnv4 entre les 2 ASBR se fait dans ce LAB avec une interface physique, dans le monde réel ce n'est pas le cas et les sous interfaces sont généralement utilisées, ce qui permet d'avoir plusieurs VRF et fournir des services telles que l'interAS MPLS VPN
Nous allons divisé notre travail en 5 étapes
1 - Nous allons préparer le réseau MPLS de MTN
- Configuration des interfaces
- Configuration de Ospf
- Activation de MPLS sur les interfaces
2- Mise en place du L3VPN
- Configuration de la VRF
- Configuration du MP-BGP entre le PE et l'ASBR
- Importation des routes dans les VRF
3 - Preparation du réseau d'INFOGENIE
- Configuration des interfaces
- Configuration de OSPF
4 Mise en place de l'InterAS
- Creation d'une seconde VRF LAN sur l'ASBR-INFOGENIE
- Configuration du vpnv4 entre les 2 ASBR
- Importation des routes de la VRF INFOGENIE vers la VRF LAN
- redistribution des routes BGP dans OSPF
/* A ce stade toutes les routes distantes sont connues dans l'AS INFOGENIE */
- Importation des routes de la VRF LAN vers la VRF INFOGENIE grâce au routes-target
/* A ce stade le réseau est convergeant
5- Gestion de la route par défaut ( Elle vient de l'IBR de INFOGENIE)
- Configuration de la route par defaut sur l'IBR-INFOGENIE ( defaut -information originate au niveau de l'IGP
- Configuration du défaut-information originale sur l'ASBR-INFOGENIE
- Redistribution des routes sur BGP
- Redistribution des routes sur OSPF
ASBR-MTN#sh run
Building configuration...
hostname ASBR-MTN
!
!
ip cef
no ip domain lookup
!
!
ip vrf INFOGENIE
rd 30992:100
route-target export 30992:100
route-target import 30992:100
route-target import 32774:100
route-target import 32774:200
!
nterface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
ip ospf 1 area 0
duplex half
mpls ip
interface GigabitEthernet2/0
ip vrf forwarding INFOGENIE
ip address 192.168.10.2 255.255.255.252
negotiation auto
!
router bgp 30992
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 30992
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf INFOGENIE
redistribute connected
neighbor 192.168.10.1 remote-as 32774
neighbor 192.168.10.1 activate
no synchronization
exit-address-family
------------
hostname P-RTR-MTN
!
!
!
ip cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
ip ospf 1 area 0
duplex half
mpls ip
!
interface GigabitEthernet2/0
ip address 10.0.0.5 255.255.255.252
ip ospf 1 area 0
negotiation auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
-----------------------
hostname PE-RTR-MTN
!
ip cef
no ip domain lookup
!
!
ip vrf INFOGENIE
rd 30992:100
route-target export 30992:100
route-target import 30992:100
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding INFOGENIE
ip address 192.168.20.1 255.255.255.252
duplex half
!
interface GigabitEthernet2/0
ip address 10.0.0.6 255.255.255.252
ip ospf 1 area 0
negotiation auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
router bgp 30992
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 30992
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf INFOGENIE
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip route vrf INFOGENIE 41.77.83.0 255.255.255.0 192.168.20.2
------------------------------------------------
CUSTOMER-RTR
hostname CLIEN-INFOGENIE
interface Loopback0
ip address 41.77.83.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.20.2 255.255.255.252
duplex half
!
ip route 0.0.0.0 0.0.0.0 192.168.20.1
!
TOTOGENIE ASBR
hostname ASBR-INFOGENIE
!
ip cef
!
ip vrf INFOGENIE
rd 32774:100
route-target export 32774:100
route-target import 30992:100
route-target import 32774:200
!
ip vrf LAN
rd 32774:200
route-target export 32774:200
route-target import 32774:100
route-target import 30992:100
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding LAN
ip address 172.24.10.2 255.255.255.252
ip ospf 2 area 0
duplex half
!
interface GigabitEthernet2/0
ip vrf forwarding INFOGENIE
ip address 192.168.10.1 255.255.255.252
negotiation auto
!
router ospf 2 vrf LAN
router-id 172.24.10.2
log-adjacency-changes
redistribute bgp 32774 subnets
!
router ospf 1
log-adjacency-changes
!
router bgp 32774
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf LAN
redistribute connected
redistribute ospf 2 vrf LAN match internal external 1 external 2
default-information originate
no synchronization
exit-address-family
!
address-family ipv4 vrf INFOGENIE
redistribute connected
neighbor 192.168.10.2 remote-as 30992
neighbor 192.168.10.2 activate
default-information originate
no synchronization
exit-address-family
!
-----------------------------------------
TOTOLINK-BRAS
hostname BRAS-INFOGENIE
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip ospf 1 area 0
!
interface Loopback100
ip address 172.24.3.1 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 172.24.10.1 255.255.255.252
ip ospf 1 area 0
duplex half
!
interface GigabitEthernet2/0
ip address 172.24.10.6 255.255.255.252
ip ospf 1 area 0
negotiation auto
!
router ospf 1
router-id 6.6.6.6
log-adjacency-changes
!
----------------------------
hostname IBR-INFOGENIE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 195.24.195.2 255.255.255.252
duplex half
!
interface GigabitEthernet2/0
ip address 172.24.10.5 255.255.255.252
ip ospf 1 area 0
negotiation auto
!
router ospf 1
router-id 7.7.7.7
log-adjacency-changes
default-information originate
!
ip route 0.0.0.0 0.0.0.0 195.24.195.1
!
end
MTN-ASBR
Réception des préfixes
PE-MTN
PING et TRACEROUTE coté CLIENT
Merci d'avoir lu, j'attend vos critiques
Dans le cadre de la préparation de mon CCIE de l'optimisation de mon réseau et de ma disponibilité je ferai toujours de plus en plus de post sur les protocoles BGP et MPLS qui en mon sens sont des protocoles indispensables chez les service provider ( SP)
Aujourd'hui nous allons voir comment il est possible à un très petit ISP présent dans un ville
de pouvoir utiliser le réseau d'un grand ISP pour pouvoir fournir la connectivité INTERNET dans tout un PAYS
Nous allons prendre pour les besoins du LAB MTNC qui est le plus gros operateur au Cameroun et INFOGENIE qui lui est plus petit et présent pour l'instant que dans la ville de Yaoundé
La problématique est comment INFOGENIE peut utiliser le réseau de MTNC pour connecter un client à Maroua en faisant trafiquer son trafic vers son propre BRAS ( ce qui permet à INFOGENIE de fabriquer lui même ses plans de services )
Nous allons fortement nous inspirer du VPN/MPLS interAs de type A encore appelé Back to Back VRF
Quelques remarques
- Nous aurions également pu simplement utiliser du L2VPN mais nous aurions eu un soucis de "scalability"
- La connectivité vpnv4 entre les 2 ASBR se fait dans ce LAB avec une interface physique, dans le monde réel ce n'est pas le cas et les sous interfaces sont généralement utilisées, ce qui permet d'avoir plusieurs VRF et fournir des services telles que l'interAS MPLS VPN
- Les routeurs utilisent Cisco IOS Software, 7200 Software (C7200-JK9S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
-Nous parlons de INTERAS INTERNET ACCESS et non INTERAS VPN MPLS, donc nous n'avons aucun problème à mettre plusieurs clients dans la même VRF
-Nous parlons de INTERAS INTERNET ACCESS et non INTERAS VPN MPLS, donc nous n'avons aucun problème à mettre plusieurs clients dans la même VRF
TOPOLOGIE
IMPLÉMENTATIONS:
Nous allons divisé notre travail en 5 étapes
1 - Nous allons préparer le réseau MPLS de MTN
- Configuration des interfaces
- Configuration de Ospf
- Activation de MPLS sur les interfaces
2- Mise en place du L3VPN
- Configuration de la VRF
- Configuration du MP-BGP entre le PE et l'ASBR
- Importation des routes dans les VRF
3 - Preparation du réseau d'INFOGENIE
- Configuration des interfaces
- Configuration de OSPF
4 Mise en place de l'InterAS
- Creation d'une seconde VRF LAN sur l'ASBR-INFOGENIE
- Configuration du vpnv4 entre les 2 ASBR
- Importation des routes de la VRF INFOGENIE vers la VRF LAN
- redistribution des routes BGP dans OSPF
/* A ce stade toutes les routes distantes sont connues dans l'AS INFOGENIE */
- Importation des routes de la VRF LAN vers la VRF INFOGENIE grâce au routes-target
/* A ce stade le réseau est convergeant
5- Gestion de la route par défaut ( Elle vient de l'IBR de INFOGENIE)
- Configuration de la route par defaut sur l'IBR-INFOGENIE ( defaut -information originate au niveau de l'IGP
- Configuration du défaut-information originale sur l'ASBR-INFOGENIE
- Redistribution des routes sur BGP
- Redistribution des routes sur OSPF
CONFIGURATIONS
Building configuration...
hostname ASBR-MTN
!
!
ip cef
no ip domain lookup
!
!
ip vrf INFOGENIE
rd 30992:100
route-target export 30992:100
route-target import 30992:100
route-target import 32774:100
route-target import 32774:200
!
nterface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
ip ospf 1 area 0
duplex half
mpls ip
interface GigabitEthernet2/0
ip vrf forwarding INFOGENIE
ip address 192.168.10.2 255.255.255.252
negotiation auto
!
router bgp 30992
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 30992
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf INFOGENIE
redistribute connected
neighbor 192.168.10.1 remote-as 32774
neighbor 192.168.10.1 activate
no synchronization
exit-address-family
------------
hostname P-RTR-MTN
!
!
!
ip cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
ip ospf 1 area 0
duplex half
mpls ip
!
interface GigabitEthernet2/0
ip address 10.0.0.5 255.255.255.252
ip ospf 1 area 0
negotiation auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
-----------------------
hostname PE-RTR-MTN
!
ip cef
no ip domain lookup
!
!
ip vrf INFOGENIE
rd 30992:100
route-target export 30992:100
route-target import 30992:100
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding INFOGENIE
ip address 192.168.20.1 255.255.255.252
duplex half
!
interface GigabitEthernet2/0
ip address 10.0.0.6 255.255.255.252
ip ospf 1 area 0
negotiation auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
router bgp 30992
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 30992
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf INFOGENIE
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip route vrf INFOGENIE 41.77.83.0 255.255.255.0 192.168.20.2
------------------------------------------------
CUSTOMER-RTR
hostname CLIEN-INFOGENIE
interface Loopback0
ip address 41.77.83.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.20.2 255.255.255.252
duplex half
!
ip route 0.0.0.0 0.0.0.0 192.168.20.1
!
TOTOGENIE ASBR
hostname ASBR-INFOGENIE
!
ip cef
!
ip vrf INFOGENIE
rd 32774:100
route-target export 32774:100
route-target import 30992:100
route-target import 32774:200
!
ip vrf LAN
rd 32774:200
route-target export 32774:200
route-target import 32774:100
route-target import 30992:100
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding LAN
ip address 172.24.10.2 255.255.255.252
ip ospf 2 area 0
duplex half
!
interface GigabitEthernet2/0
ip vrf forwarding INFOGENIE
ip address 192.168.10.1 255.255.255.252
negotiation auto
!
router ospf 2 vrf LAN
router-id 172.24.10.2
log-adjacency-changes
redistribute bgp 32774 subnets
!
router ospf 1
log-adjacency-changes
!
router bgp 32774
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf LAN
redistribute connected
redistribute ospf 2 vrf LAN match internal external 1 external 2
default-information originate
no synchronization
exit-address-family
!
address-family ipv4 vrf INFOGENIE
redistribute connected
neighbor 192.168.10.2 remote-as 30992
neighbor 192.168.10.2 activate
default-information originate
no synchronization
exit-address-family
!
-----------------------------------------
TOTOLINK-BRAS
hostname BRAS-INFOGENIE
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip ospf 1 area 0
!
interface Loopback100
ip address 172.24.3.1 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 172.24.10.1 255.255.255.252
ip ospf 1 area 0
duplex half
!
interface GigabitEthernet2/0
ip address 172.24.10.6 255.255.255.252
ip ospf 1 area 0
negotiation auto
!
router ospf 1
router-id 6.6.6.6
log-adjacency-changes
!
----------------------------
hostname IBR-INFOGENIE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 195.24.195.2 255.255.255.252
duplex half
!
interface GigabitEthernet2/0
ip address 172.24.10.5 255.255.255.252
ip ospf 1 area 0
negotiation auto
!
router ospf 1
router-id 7.7.7.7
log-adjacency-changes
default-information originate
!
ip route 0.0.0.0 0.0.0.0 195.24.195.1
!
end
------------------------------------------------
hostname CAMTEL
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
interface FastEthernet0/0
ip address 195.24.195.1 255.255.255.252
duplex half
!
ip route 41.77.80.0 255.255.255.0 195.24.195.2
ip route 172.24.0.0 255.255.0.0 195.24.195.2
ip route 192.168.0.0 255.255.0.0 195.24.195.2
Table de routage de l'IBR
Table de routage sur l'ASBR-INFOGENIE
MTN-ASBR
Réception des préfixes
PE-MTN
PING et TRACEROUTE coté CLIENT
Merci d'avoir lu, j'attend vos critiques
Super Fabrice pour le concept . techniquement je ne peux rien t'apporter j'admire ton idée
RépondreSupprimer